Ticket Support
Incident Report for GridPlay
Resolved
ok for now we going to stick with Hesk for tickets and Tawk.to for live chat. Also there's our discord as well for help
Posted Jul 08, 2020 - 09:14 PDT
Investigating
We are currently finding the best ticket support software to better serve you all. You may see different types pop up. Please monitor this incident to find out when we settle on a system. ty
Posted Jul 08, 2020 - 09:05 PDT